summaryrefslogtreecommitdiff
path: root/fw/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/app/CMakeLists.txt')
-rw-r--r--fw/app/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/fw/app/CMakeLists.txt b/fw/app/CMakeLists.txt
new file mode 100644
index 0000000..ce10104
--- /dev/null
+++ b/fw/app/CMakeLists.txt
@@ -0,0 +1,41 @@
+# This Source Code Form is subject to the terms of the Mozilla Public License,
+# v. 2.0. If a copy of the MPL was not distributed with this file, You can
+# obtain one at https://mozilla.org/MPL/2.0/.
+
+cmake_minimum_required(VERSION 3.20.0)
+
+find_package(Zephyr
+ REQUIRED
+ HINTS
+ "${ZEPHYR_BASE}"
+)
+
+project(iot-contact-fw)
+
+target_sources(app
+ PRIVATE
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/syslog.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/network.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/http.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/ws.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/heart.c"
+)
+
+zephyr_linker_sources(SECTIONS sections-rom.ld)
+zephyr_linker_section(NAME http_resource_desc_http_service
+ KVMA RAM_REGION GROUP RODATA_REGION
+ SUBALIGN ${CONFIG_LINKER_ITERABLE_SUBALIGN})
+
+generate_inc_file_for_target(
+ app
+ src/index.html
+ ${ZEPHYR_BINARY_DIR}/include/generated/index.html.gz.inc
+ --gzip
+)
+
+generate_inc_file_for_target(
+ app
+ src/iot-contact.js
+ ${ZEPHYR_BINARY_DIR}/include/generated/iot-contact.js.gz.inc
+ --gzip
+)