summaryrefslogtreecommitdiff
path: root/fw/app/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'fw/app/meson.build')
-rw-r--r--fw/app/meson.build16
1 files changed, 15 insertions, 1 deletions
diff --git a/fw/app/meson.build b/fw/app/meson.build
index 97c17f1..ddd5aa6 100644
--- a/fw/app/meson.build
+++ b/fw/app/meson.build
@@ -41,5 +41,19 @@ application_signed = custom_target(
build_by_default: true,
depends: application,
install: true,
- install_dir: 'website/static',
+ install_dir: '/',
+)
+
+flash_application = custom_target(
+ build_always_stale: true,
+ build_by_default: false,
+ command: [
+ 'st-flash',
+ '--connect-under-reset',
+ 'write',
+ meson.current_build_dir() / 'application.signed.bin',
+ '0x8040000',
+ ],
+ depends: application_signed,
+ output: ['flash'],
)