summaryrefslogtreecommitdiff
path: root/fw/btl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'fw/btl/meson.build')
-rw-r--r--fw/btl/meson.build19
1 files changed, 1 insertions, 18 deletions
diff --git a/fw/btl/meson.build b/fw/btl/meson.build
index 8ca1eb3..204fe20 100644
--- a/fw/btl/meson.build
+++ b/fw/btl/meson.build
@@ -14,7 +14,7 @@ external_project.add_project(
verbose: true,
)
-bootloader = custom_target('bootloader',
+bootloader = custom_target(
output: ['bootloader.bin'],
command: [
build_zephyr,
@@ -22,21 +22,4 @@ bootloader = custom_target('bootloader',
'--binary-name', 'zephyr.bin',
'--target-name', 'bootloader.bin',
],
- build_by_default: true,
- install: true,
- install_dir: '/',
-)
-
-flash_bootloader = custom_target(
- build_always_stale: true,
- build_by_default: false,
- command: [
- 'st-flash',
- '--connect-under-reset',
- 'write',
- meson.current_build_dir() / 'bootloader.bin',
- '0x8000000',
- ],
- depends: bootloader,
- output: ['flash'],
)