summaryrefslogtreecommitdiff
path: root/fw/rtos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/rtos/CMakeLists.txt')
-rw-r--r--fw/rtos/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/fw/rtos/CMakeLists.txt b/fw/rtos/CMakeLists.txt
new file mode 100644
index 0000000..d9f116c
--- /dev/null
+++ b/fw/rtos/CMakeLists.txt
@@ -0,0 +1,16 @@
+# This Source Code Form is subject to the terms of the Mozilla Public License,
+# v. 2.0. If a copy of the MPL was not distributed with this file, You can
+# obtain one at https://mozilla.org/MPL/2.0/.
+
+set(ZEPHYR_MODULES
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/cmsis"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/hal_stm32"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/mbedtls"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/mcuboot"
+ PARENT_SCOPE
+)
+
+set(ZEPHYR_BASE
+ "${CMAKE_CURRENT_SOURCE_DIR}/zephyr"
+ PARENT_SCOPE
+)