summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build24
1 files changed, 4 insertions, 20 deletions
diff --git a/web/meson.build b/web/meson.build
index da45440..f8c2024 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,22 +1,6 @@
-website = custom_target('website',
- output: ['index.html'],
- command: [
- 'hugo',
- '--source', meson.current_source_dir(),
- '--destination', meson.current_build_dir(),
- ],
- depend_files: [
- 'hugo.toml',
- 'layouts/baseof.html',
- 'layouts/home.html',
- ],
- depends: [
- schematic,
- bom,
- application,
- bootloader,
- ],
- build_by_default: true,
+website = fs.copyfile(
+ meson.current_source_dir() / 'index.html',
+ 'index.html',
install: true,
- install_dir: 'website',
+ install_dir: '/',
)