summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/web/meson.build b/web/meson.build
new file mode 100644
index 0000000..743aa77
--- /dev/null
+++ b/web/meson.build
@@ -0,0 +1,21 @@
+hugo_toml = 'hugo.toml'
+
+configure_file(
+ input: hugo_toml,
+ output: hugo_toml,
+ copy: true,
+)
+
+subdir('layouts')
+
+custom_target('website',
+ output: ['public'],
+ command: [
+ 'hugo',
+ '--source',
+ meson.current_build_dir(),
+ '--destination',
+ meson.current_build_dir() / 'public',
+ ],
+ build_by_default: true,
+)