summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/web/meson.build b/web/meson.build
new file mode 100644
index 0000000..da45440
--- /dev/null
+++ b/web/meson.build
@@ -0,0 +1,22 @@
+website = custom_target('website',
+ output: ['index.html'],
+ command: [
+ 'hugo',
+ '--source', meson.current_source_dir(),
+ '--destination', meson.current_build_dir(),
+ ],
+ depend_files: [
+ 'hugo.toml',
+ 'layouts/baseof.html',
+ 'layouts/home.html',
+ ],
+ depends: [
+ schematic,
+ bom,
+ application,
+ bootloader,
+ ],
+ build_by_default: true,
+ install: true,
+ install_dir: 'website',
+)