summaryrefslogtreecommitdiff
path: root/firmware/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2024-04-13 21:21:54 +0200
committerxengineering <me@xengineering.eu>2024-04-13 21:21:54 +0200
commitfedaacedd29b4b61fc138e381aad2cf4be08f31d (patch)
treec47a9486e2991e02e257676498aff9014937df38 /firmware/CMakeLists.txt
parent31bdbcf1a38f0d513ca3327441432a281a5ce6d8 (diff)
downloadiot-core-fedaacedd29b4b61fc138e381aad2cf4be08f31d.tar
iot-core-fedaacedd29b4b61fc138e381aad2cf4be08f31d.tar.zst
iot-core-fedaacedd29b4b61fc138e381aad2cf4be08f31d.zip
firmware: Add minimal Zephyr application
This is enough to validate that the firmware is running by using the Zephyr shell.
Diffstat (limited to 'firmware/CMakeLists.txt')
-rw-r--r--firmware/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/firmware/CMakeLists.txt b/firmware/CMakeLists.txt
new file mode 100644
index 0000000..70b99c7
--- /dev/null
+++ b/firmware/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 3.20.0)
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+project(iot-core)
+
+target_sources(app PRIVATE src/main.c)