summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2022-10-07 21:18:21 +0200
committerxengineering <me@xengineering.eu>2022-10-07 21:18:21 +0200
commitd7e9d2932e4497711fffa2d649a036b7581e2c89 (patch)
tree5125a520b8b525189a5f366c3a0b5323e9fbf74f /meson.build
parentb726bd936ce416044d447ce81409dcc0a9d9aaae (diff)
downloadlimox-d7e9d2932e4497711fffa2d649a036b7581e2c89.tar
limox-d7e9d2932e4497711fffa2d649a036b7581e2c89.tar.zst
limox-d7e9d2932e4497711fffa2d649a036b7581e2c89.zip
Add SDL2 version (X11 only)
There seems to be a bug in SDL2. Window creation is successful under Wayland (window pointer not NULL) but there is no window visible. Tested with Sway and Weston. The same implementation works fine under Cinnamon with X11.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9a5f339..205b210 100644
--- a/meson.build
+++ b/meson.build
@@ -2,5 +2,7 @@ project('LimoX', 'c')
gtkdep = dependency('gtk4')
strophedep = dependency('libstrophe')
sdldep = dependency('sdl')
+sdl2dep = dependency('sdl2')
executable('limox', ['main.c', 'gtk.c', 'net.c', 'data.c'], dependencies : [gtkdep, strophedep])
executable('limox_sdl', ['main.c', 'sdl.c', 'net.c', 'data.c'], dependencies : [sdldep, strophedep])
+executable('limox_sdl2', ['main.c', 'sdl2.c', 'net.c', 'data.c'], dependencies : [sdl2dep, strophedep])