summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2024-03-10 18:16:23 +0100
committerxengineering <me@xengineering.eu>2024-03-10 18:24:41 +0100
commitafa66ca4430deecb98a1283233fd95d4f21dce6c (patch)
treeab6f58388501c80ac0aedfef63721b0add1a9e09 /CMakeLists.txt
parent37e36090d102be2e8f52e5ab43509e40b2e5754e (diff)
downloadradio-gateway-main.tar
radio-gateway-main.tar.zst
radio-gateway-main.zip
Implement LoRa RX to log outputHEADmain
This is the first step towards a minimal viable product. While sending is not possible all received frames are logged.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..99d7134
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 3.20.0)
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+project(radio-gateway)
+
+target_sources(app PRIVATE src/main.c)