summaryrefslogtreecommitdiff
path: root/archlinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'archlinux/PKGBUILD')
-rw-r--r--archlinux/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/archlinux/PKGBUILD b/archlinux/PKGBUILD
new file mode 100644
index 0000000..b77f4e0
--- /dev/null
+++ b/archlinux/PKGBUILD
@@ -0,0 +1,41 @@
+
+# Maintainer: xengineering <me@xengineering.eu>
+pkgname=xbackup
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc='Convenience wrapper around the Borg backup tool'
+arch=('any')
+url='https://xengineering.eu'
+license=('GPL3')
+groups=()
+depends=('licenses' 'python' 'borg')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=('etc/xbackup/config.json')
+options=()
+install=
+changelog=
+source=("${pkgname}.tar.gz")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ #./configure --prefix=/usr
+ cd ${pkgname}
+ make all
+}
+
+#check() {
+# make -k check
+#}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}