summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f83b318
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/python3
+# vim: shiftwidth=4 softtabstop=4 tabstop=4 expandtab
+
+
+"""setup.py
+
+Configuration file for setuptools.
+"""
+
+
+from distutils.core import setup
+
+
+setup(
+ name="xbackup",
+ version="1.0.0-dev",
+ description="Convenience wrapper around the Borg backup tool",
+ author="xengineering",
+ author_email="me@xengineering.eu",
+ url="https://xengineering.eu",
+ packages=["xbackup"],
+ scripts=["main.py"],
+)