summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-25 21:18:25 +0100
committerxengineering <me@xengineering.eu>2025-03-26 21:18:23 +0100
commit7c73e4958f3be36ee80ae978d7c52db15949954b (patch)
tree9891611681623e522b21185e3b14f351e9a82edb /fw/CMakeLists.txt
parent42126a39b96817fed111a9ec271688681382f4b0 (diff)
downloadiot-contact-7c73e4958f3be36ee80ae978d7c52db15949954b.tar
iot-contact-7c73e4958f3be36ee80ae978d7c52db15949954b.tar.zst
iot-contact-7c73e4958f3be36ee80ae978d7c52db15949954b.zip
fw: Move MCUboot key definition here
This key is only relevant for firmware. Thus it should be set in the CMakeLists.txt file of the `fw` folder.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 0eca50f..db9834c 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -4,6 +4,10 @@
cmake_minimum_required(VERSION 3.20.0)
+set(KEY_DEFAULT "$ENV{HOME}/mcuboot/key.pem")
+set(KEY ${KEY_DEFAULT} CACHE STRING "Firmware signing key path")
+message(STATUS "Firmware signing key path: ${KEY}")
+
set(BOARD "native_sim/native/64")
set(ZEPHYR_MODULES
"${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/cmsis"