summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 0eca50f..db9834c 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -4,6 +4,10 @@
cmake_minimum_required(VERSION 3.20.0)
+set(KEY_DEFAULT "$ENV{HOME}/mcuboot/key.pem")
+set(KEY ${KEY_DEFAULT} CACHE STRING "Firmware signing key path")
+message(STATUS "Firmware signing key path: ${KEY}")
+
set(BOARD "native_sim/native/64")
set(ZEPHYR_MODULES
"${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/cmsis"