summaryrefslogtreecommitdiff
path: root/fw/app/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-27 21:19:30 +0100
committerxengineering <me@xengineering.eu>2025-03-30 18:51:33 +0200
commitb2afe2a52d421a6f9ce87d6b20c0230f93ecbdc4 (patch)
tree8a6f219e1a1d08a4088824a68e28615fe44a4966 /fw/app/CMakeLists.txt
parentb188fdb33ac91cad157550723f6e747a065c76db (diff)
downloadiot-contact-b2afe2a52d421a6f9ce87d6b20c0230f93ecbdc4.tar
iot-contact-b2afe2a52d421a6f9ce87d6b20c0230f93ecbdc4.tar.zst
iot-contact-b2afe2a52d421a6f9ce87d6b20c0230f93ecbdc4.zip
fw: app: update: Add source file and HTTP 204 handler
This adds the HTTP PUT /update handler which just returns HTTP 204 No Content. This is the minimal first step towards a working /update handler.
Diffstat (limited to 'fw/app/CMakeLists.txt')
-rw-r--r--fw/app/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/fw/app/CMakeLists.txt b/fw/app/CMakeLists.txt
index 47f75f6..1a9d1cf 100644
--- a/fw/app/CMakeLists.txt
+++ b/fw/app/CMakeLists.txt
@@ -21,6 +21,13 @@ target_sources(app
"${CMAKE_CURRENT_SOURCE_DIR}/src/heart.c"
)
+target_sources_ifdef(
+ CONFIG_IOT_CONTACT_REMOTE_UPDATE
+ app
+ PRIVATE
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/update.c"
+)
+
zephyr_linker_sources(SECTIONS sections-rom.ld)
zephyr_linker_section(NAME http_resource_desc_http_service
KVMA RAM_REGION GROUP RODATA_REGION