summaryrefslogtreecommitdiff
path: root/fw/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/app/CMakeLists.txt')
-rw-r--r--fw/app/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/fw/app/CMakeLists.txt b/fw/app/CMakeLists.txt
index 47f75f6..1a9d1cf 100644
--- a/fw/app/CMakeLists.txt
+++ b/fw/app/CMakeLists.txt
@@ -21,6 +21,13 @@ target_sources(app
"${CMAKE_CURRENT_SOURCE_DIR}/src/heart.c"
)
+target_sources_ifdef(
+ CONFIG_IOT_CONTACT_REMOTE_UPDATE
+ app
+ PRIVATE
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/update.c"
+)
+
zephyr_linker_sources(SECTIONS sections-rom.ld)
zephyr_linker_section(NAME http_resource_desc_http_service
KVMA RAM_REGION GROUP RODATA_REGION