summaryrefslogtreecommitdiff
path: root/fw/app/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-12 11:33:07 +0200
committerxengineering <me@xengineering.eu>2025-04-12 11:33:07 +0200
commitddcf8559d4fbb9bd6942ac46d5c4970ef08b16d1 (patch)
treeee0873b4d7b0b10486a90ffab72ae4548434bf81 /fw/app/meson.build
parentd9a9ea56e6b733a6b054e662d5d4b0ce015a219c (diff)
downloadiot-contact-ddcf8559d4fbb9bd6942ac46d5c4970ef08b16d1.tar
iot-contact-ddcf8559d4fbb9bd6942ac46d5c4970ef08b16d1.tar.zst
iot-contact-ddcf8559d4fbb9bd6942ac46d5c4970ef08b16d1.zip
fw: Add flash and erase targets
These targets are added: - fw/erase - fw/app/flash - fw/btl/flash They make it easier to perform a mass-erase, flashing of the bootloader and flashing of the application for development.
Diffstat (limited to 'fw/app/meson.build')
-rw-r--r--fw/app/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/fw/app/meson.build b/fw/app/meson.build
index 8d84209..ddd5aa6 100644
--- a/fw/app/meson.build
+++ b/fw/app/meson.build
@@ -43,3 +43,17 @@ application_signed = custom_target(
install: true,
install_dir: '/',
)
+
+flash_application = custom_target(
+ build_always_stale: true,
+ build_by_default: false,
+ command: [
+ 'st-flash',
+ '--connect-under-reset',
+ 'write',
+ meson.current_build_dir() / 'application.signed.bin',
+ '0x8040000',
+ ],
+ depends: application_signed,
+ output: ['flash'],
+)