summaryrefslogtreecommitdiff
path: root/fw/app/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'fw/app/meson.build')
-rw-r--r--fw/app/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/fw/app/meson.build b/fw/app/meson.build
index 8d84209..ddd5aa6 100644
--- a/fw/app/meson.build
+++ b/fw/app/meson.build
@@ -43,3 +43,17 @@ application_signed = custom_target(
install: true,
install_dir: '/',
)
+
+flash_application = custom_target(
+ build_always_stale: true,
+ build_by_default: false,
+ command: [
+ 'st-flash',
+ '--connect-under-reset',
+ 'write',
+ meson.current_build_dir() / 'application.signed.bin',
+ '0x8040000',
+ ],
+ depends: application_signed,
+ output: ['flash'],
+)