summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2022-11-27 18:53:12 +0100
committerxengineering <me@xengineering.eu>2022-11-27 19:07:49 +0100
commit2efc9022bf064136bb7cd25bd59971f2b419ff48 (patch)
tree87ea72030a3bb28f1ddba1675482a9346c5df814 /meson.build
parent8b9ce1d7848bd8ad417a3834d11e1b00c028f8eb (diff)
downloadlimox-2efc9022bf064136bb7cd25bd59971f2b419ff48.tar
limox-2efc9022bf064136bb7cd25bd59971f2b419ff48.tar.zst
limox-2efc9022bf064136bb7cd25bd59971f2b419ff48.zip
Switch completely to SDL2 version
The now legacy version of LimoX with GTK4 and libstrophe is now not part of the main branch anymore. There might be a legacy branch keeping this version at the time of reading. This cut of implemented functionality is motivated by these reasons: - Implementing XMPP is fun, educative and gives full control. - Low level graphics with SDL2 is portable, fast, educative an mature. - I do not have to use GLib and a crazy event loop anymore (run and hide)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 8a21907..a675aa6 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,3 @@
project('LimoX', 'c')
-gtkdep = dependency('gtk4')
-strophedep = dependency('libstrophe')
sdl2dep = dependency('sdl2')
-executable('limox', ['main.c', 'gtk.c', 'strophe.c', 'data.c'], dependencies : [gtkdep, strophedep])
-executable('limox_sdl2', ['main.c', 'sdl2.c', 'xmpp.c', 'data.c'], dependencies : [sdl2dep])
+executable('limox', ['main.c', 'gui.c', 'xmpp.c'], dependencies : [sdl2dep])